aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..36eead0
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,42 @@
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+
+from setuptools.command.test import test
+from setuptools import setup
+import sys
+
+
+class Tox(test):
+ def initialize_options(self):
+ test.initialize_options(self)
+ self.tox_args = None
+
+ def finalize_options(self):
+ test.finalize_options(self)
+ self.test_args = []
+ self.test_suite = True
+
+ def run_tests(self):
+ import tox
+ sys.exit(tox.cmdline())
+
+
+if __name__ == '__main__':
+ setup(setup_requires=['pbr'], pbr=True,
+ tests_require=['tox'],
+ cmdclass={'test': Tox})