summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2017-08-07 10:25:35 +0200
committerCédric Ollivier <cedric.ollivier@orange.com>2017-08-07 14:29:12 +0200
commit38697bcef2049dc3f99e21dbfe7f591c987fb780 (patch)
tree5823f26442c4d384c35b5806c2b8bdc19b523112
parentd44958177833bfebb9a168fb511c07261930ea1e (diff)
Add netready packageHEADmaster
It eases how Functest installs/runs it (see testcases.yaml [1]). [1] https://git.opnfv.org/functest/tree/functest/ci/testcases.yaml Change-Id: I3842e6828f60972cb1df0bc15f849cd08badd895 Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
-rw-r--r--test/functest/requirements.txt2
-rw-r--r--test/functest/setup.cfg8
-rw-r--r--test/functest/setup.py22
3 files changed, 32 insertions, 0 deletions
diff --git a/test/functest/requirements.txt b/test/functest/requirements.txt
new file mode 100644
index 0000000..8a54c34
--- /dev/null
+++ b/test/functest/requirements.txt
@@ -0,0 +1,2 @@
+opnfv
+functest
diff --git a/test/functest/setup.cfg b/test/functest/setup.cfg
new file mode 100644
index 0000000..0b9f6bb
--- /dev/null
+++ b/test/functest/setup.cfg
@@ -0,0 +1,8 @@
+[metadata]
+name = netready
+version = 5
+home-page = https://wiki.opnfv.org/display/netready/NetReady
+
+[files]
+packages = .
+scripts = gluon-test-suite.py
diff --git a/test/functest/setup.py b/test/functest/setup.py
new file mode 100644
index 0000000..a1e9b3b
--- /dev/null
+++ b/test/functest/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)