summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorLeif Madsen <lmadsen@redhat.com>2016-10-28 05:59:53 -0400
committerzshi <zshi@redhat.com>2016-12-13 12:48:12 +0800
commitef7fd4008481b5b98316240b0703d2c78fbd30e8 (patch)
tree54a49e56fbdacfb9eac3a6015629f58c2bbed16a /setup.py
parenta372d5dff98c600f0318ac8e60e7db37cd47aaa8 (diff)
[WIP] Migrate to tox based environment
Migrate the custom setup.py to a more formal setup environment using tox, in the same way that OpenStack configures their projects. Adds metadata to tox.ini from the setup.py file, and breaks out the dependencies from setup.py into requirements.txt and test-requirements.txt. Executes flake8 testing for pep8 coverage. Defaults to using Python 2 for the environment. Change-Id: Ieaea7d9f3dc227febd8fb1dc9142d478ba197a92 Signed-off-by: Leif Madsen <lmadsen@redhat.com> Signed-off-by: zshi <zshi@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 4 insertions, 28 deletions
diff --git a/setup.py b/setup.py
index 40dc4751..b9f6e141 100644
--- a/setup.py
+++ b/setup.py
@@ -7,32 +7,8 @@
# http://www.apache.org/licenses/LICENSE-2.0
##############################################################################
-from setuptools import setup, find_packages
+import setuptools
-
-setup(
- name="dovetail",
- version="0.dev0",
- packages=find_packages(),
- include_package_data=True,
- package_data={
- 'dovetail': [
- '*.py',
- 'conf/*.py',
- 'conf/*.yml',
- 'utils/*.py',
- ]
- },
- url="https://www.opnfv.org",
- install_requires=["coverage>=3.6",
- "flake8",
- "Jinja2>=2.6",
- "PyYAML>=3.10",
- "Click"
- ],
- entry_points={
- 'console_scripts': [
- 'dovetail=dovetail.main:main',
- ],
- }
-)
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)