summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatthewLi <matthew.lijun@huawei.com>2017-03-30 06:52:41 -0400
committerMatthewLi <matthew.lijun@huawei.com>2017-03-30 06:53:48 -0400
commit33cdf9599104a610e2681614ec010a4c2a8ac112 (patch)
tree29651645279f6f055da852a789d45fea765d0797 /setup.py
parentaa8654d4f3f727f99016aaa540c8d5aa3f79edcb (diff)
bugfix of pbr after updating
JIRA: DOVETAIL-388 Change-Id: I3611624c955fa735aabfd00b456bd7f8455080e5 Signed-off-by: MatthewLi <matthew.lijun@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a84dd400..03ea2988 100644
--- a/setup.py
+++ b/setup.py
@@ -9,6 +9,14 @@
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr==2.0.0'],
pbr=True)