summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatthewLi <matthew.lijun@huawei.com>2016-10-12 23:51:50 -0400
committerMatthewLi <matthew.lijun@huawei.com>2016-10-13 23:14:35 -0400
commit2c7f65363fc429fbf58bacfae9edbf8e601d01c7 (patch)
treebefbfa46d1111a005d997596d0e411c4581b42a4 /setup.py
parent690d329a91af99777a0d48cdd2ea84ac7e803c0e (diff)
dovetail tool: setup.py added and path error amend
JIRA: DOVETAIL-26 1)ez_setup.py setup.py is added 2)flake8 is there, then format check can be easily achived in CI later 3)path error amend see details in DOVETAIL-33 Change-Id: Ic19dbac852694adaeecf5cdf6c2ae7c9ea9dbb33 Signed-off-by: MatthewLi <matthew.lijun@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..40dc4751
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,38 @@
+##############################################################################
+# Copyright (c) 2016 Huawei Technologies Co.,Ltd and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="dovetail",
+ version="0.dev0",
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ 'dovetail': [
+ '*.py',
+ 'conf/*.py',
+ 'conf/*.yml',
+ 'utils/*.py',
+ ]
+ },
+ url="https://www.opnfv.org",
+ install_requires=["coverage>=3.6",
+ "flake8",
+ "Jinja2>=2.6",
+ "PyYAML>=3.10",
+ "Click"
+ ],
+ entry_points={
+ 'console_scripts': [
+ 'dovetail=dovetail.main:main',
+ ],
+ }
+)