aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j2
diff options
context:
space:
mode:
authorramamani yeleswarapu <ramamani.yeleswarapu@intel.com>2018-03-26 14:23:49 -0700
committerJustin chi <chigang@huawei.com>2018-04-25 08:48:21 +0000
commitab73374e424a679cc42b9812e6bd39a49fcea07d (patch)
treeb6e3c22f2df57577f12324425668b42b01f61009 /plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j2
parent84036899c0ec4bde40c6b71e2c8d447bbdb79b0c (diff)
Stor4nfv: Install ansible version 2.4opnfv-6.0.0
Ansible 2.5 release is causing errors in the installation of ceph-ansible (for ceph-mon). This patch fixes the ansible version installed on kube_master to 2.4.3 to address the ceph errors. Also, adds these post-install tasks: - run 'modprobe rbd' - create opensds default profile - create csi pods. Change-Id: Iee8d27da68896009d2e27ce4a6c7f805524d086d Signed-off-by: Ramamani Yeleswarapu <ramamani.yeleswarapu@intel.com>
Diffstat (limited to 'plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j2')
-rw-r--r--plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j220
1 files changed, 20 insertions, 0 deletions
diff --git a/plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j2 b/plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j2
new file mode 100644
index 0000000..662abc3
--- /dev/null
+++ b/plugins/stor4nfv/roles/stor4nfv/templates/post-install.yml.j2
@@ -0,0 +1,20 @@
+# #############################################################################
+# Copyright (c) 2018 Intel Corp.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+# #############################################################################
+---
+
+- hosts:
+ - mons
+ - osds
+ - mgrs
+
+ tasks:
+ - name: run modprobe rbd
+ remote_user: root
+ command: modprobe rbd
+ ignore_errors: "true"