summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorQiLiang <liangqi1@huawei.com>2018-03-28 16:54:40 +0800
committerQiLiang <liangqi1@huawei.com>2018-03-28 16:56:39 +0800
commit4b979c56cce1964684b5693b0552eccc7a837be1 (patch)
tree92bafb56c04c72ad9ca5e5807af7bc231c6043bb /setup.py
parent721d284c2147c9565a10e17beedf6da81722728c (diff)
Add Functest test hook
Change-Id: Idbe25c162fb19c59ad4e57fd32a749d1d5a29f63 Signed-off-by: QiLiang <liangqi1@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..566d844
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
+setuptools.setup(
+ setup_requires=['pbr>=2.0.0'],
+ pbr=True)