summaryrefslogtreecommitdiffstats
path: root/test-scheduler/server/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'test-scheduler/server/setup.py')
-rw-r--r--test-scheduler/server/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/test-scheduler/server/setup.py b/test-scheduler/server/setup.py
new file mode 100644
index 00000000..0062cfab
--- /dev/null
+++ b/test-scheduler/server/setup.py
@@ -0,0 +1,31 @@
+#!/usr/bin/env python
+##############################################################################
+# Copyright (c) 2018 Huawei Technologies Co.,Ltd and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+'''This file realize the function of how to setup server of test-scheduler
+to your environment. This use setuptools tool to setup'''
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="test-scheduler-server",
+ version="0.1",
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ 'src': [
+ 'env/context/*.yaml',
+ 'env/service/*.yaml',
+ 'conductor_processor/*.json'
+ ],
+ 'test': [
+ 'test_case/*/*.yaml'
+ ]
+ }
+)