summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorliyin <liyin11@huawei.com>2017-01-24 17:26:21 +0800
committerAce Lee <liyin11@huawei.com>2017-02-07 02:00:00 +0000
commitc6755e612b322facefc4edc32e948ab2b00bb3b0 (patch)
treef3796ea159c10c9e9690c8b9072f37ebc0ea1f9c /setup.py
parentca641fcdaa919afb072a9625eb9ba3848b9e3805 (diff)
Bottlenecks POSCA testing code reconstruction
JIRA:BOTTLENECK-103 This is the foundation of adding stack samples. This code change a lot code. but it's a basic. Those code will be changed in the furture. Change-Id: I8d5bbb9cc401b1aaac54ec4dffc4c005a42d17ac Signed-off-by: liyin <liyin11@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py46
1 files changed, 29 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 55b89cc1..d9852c95 100644
--- a/setup.py
+++ b/setup.py
@@ -7,26 +7,38 @@
# which accompanies this distribution, and is available at
# http://www.apache.org/licenses/LICENSE-2.0
##############################################################################
+'''This file realize the function of how to setup bottlenecks to your environment
+This use setuptools tool to setup'''
from setuptools import setup, find_packages
setup(
- name="bottlenecks",
- version="master",
- py_modules=['bottlenecks_cli'],
- packages=find_packages(),
- include_package_data=True,
- package_data={
- 'utils': [
- 'utils/infra_setup/heat/*.py'
- ]
- },
- url="https://www.opnfv.org",
- install_requires=["click"],
- entry_points={
- 'console_scripts': [
- 'bottlenecks=cli.bottlenecks_cli:main'
- ],
- },
+ name="bottlenecks",
+ version="master",
+ py_modules=['bottlenecks_cli'],
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ 'utils': [
+ 'utils/infra_setup/heat/*.py',
+ 'utils/infra_setup/runner/*.py'
+ ],
+ 'config': [
+ '*.yaml'
+ ],
+ 'testsuites': [
+ 'posca/testcase_cfg/*',
+ 'posca/testcase_script/*',
+ 'posca/testsuite_story/*',
+ 'posca/testcase_dashboard/*'
+ ],
+ },
+ url="https://www.opnfv.org",
+ install_requires=["click"],
+ entry_points={
+ 'console_scripts': [
+ 'bottlenecks=cli.bottlenecks_cli:main'
+ ],
+ },
)