summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authoryuyang <Gabriel.yuyang@huawei.com>2016-11-26 23:07:41 +0800
committeryuyang <Gabriel.yuyang@huawei.com>2016-11-28 19:29:38 +0800
commit7aaf17f0cfbcfcf12cb2e0424d9f3603b11431c3 (patch)
treea4198d071f59313263d7df1603c5201d3569b51c /setup.py
parentcefb61eb31acce1c04cf31c42a7b17fd9d00a5b5 (diff)
Add CLI framework for Bottlenecks
JIRA: BOTTLENECK-65 Adding cli framwork for Bottlenecks. Usage: bottlenecks testcase run <testcase> Currently only the cli framwork and testcase command group is added. run, list, etc., commands and openstack command group will added afterwards. Two setup entries are added. One is within the top directory and the other is within the cli directory. Change-Id: I304f6f2e9b29b9f582953c2739806c1fb3e87fed Signed-off-by: yuyang <Gabriel.yuyang@huawei.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..38b8546b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python
+##############################################################################
+# Copyright (c) 2016 Huawei Technologies Co.,Ltd and others.
+#
+# All rights reserved. This program and the accompanying materials
+# are made available under the terms of the Apache License, Version 2.0
+# which accompanies this distribution, and is available at
+# http://www.apache.org/licenses/LICENSE-2.0
+##############################################################################
+
+from setuptools import setup, find_packages
+
+
+setup(
+ name="bottlenecks",
+ version="master",
+ py_modules=['bottlenecks_cli'],
+ packages=find_packages(),
+ include_package_data=True,
+ package_data={
+ },
+ url="https://www.opnfv.org",
+ install_requires=["click"],
+ entry_points={
+ 'console_scripts': [
+ 'bottlenecks=cli.bottlenecks_cli:main'
+ ],
+ },
+)