aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Ollivier <cedric.ollivier@orange.com>2017-08-29 21:21:02 +0200
committerCédric Ollivier <cedric.ollivier@orange.com>2017-08-29 21:24:31 +0200
commite27f5ce3bf1f0e92ec713babffcd1402095c57e0 (patch)
tree20efb228e4306518e7388dc70854d8f8cab964a1 /setup.py
parent151a5d6db45763a4c130a37d69f120704fac8039 (diff)
Leverage on pbr (Python Build Reasonableness)
It also removes the exec right on mce-inject_ea and installs it in $PATH. requirements.txt is also created to install the abstract dependencies. Change-Id: I176df99d2f40e1910079f5efa3f28a8c170a922d Signed-off-by: Cédric Ollivier <cedric.ollivier@orange.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 15 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 8d370483..a1e9b3bb 100644
--- a/setup.py
+++ b/setup.py
@@ -1,18 +1,22 @@
-##############################################################################
+#!/usr/bin/env python
+
+# Copyright (c) 2017 Orange and others.
+#
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Apache License, Version 2.0
# which accompanies this distribution, and is available at
# http://www.apache.org/licenses/LICENSE-2.0
-##############################################################################
-
-from setuptools import setup, find_packages
+import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
-setup(
- name="baro_tests",
- version="danube",
- packages=find_packages(),
- include_package_data=True,
- package_data={},
- url="https://www.opnfv.org")
+setuptools.setup(
+ setup_requires=['pbr>=1.8'],
+ pbr=True)