aboutsummaryrefslogtreecommitdiffstats
path: root/puppet-barometer/setup.py
diff options
context:
space:
mode:
authorMaryam Tahhan <maryam.tahhan@intel.com>2017-11-15 10:19:45 +0000
committerMaryam Tahhan <maryam.tahhan@intel.com>2017-11-15 10:21:25 +0000
commitcea670d32822b35502898c46a5a4b20b7363d46d (patch)
tree56d6a6d87efda583cea03e3fbea1dab7520d6c5f /puppet-barometer/setup.py
parentecf1ba1c5000718d1f0d90270af33039b488c835 (diff)
puppet-barometer: add puppet module to barometer
Port puppet module from https://github.com/johnhinman/puppet-barometer to barometer. Change-Id: I48499382307a184a34591a7202c439cd7c341c39 Signed-off-by: jhinman1 <john.hinman@intel.com> Signed-off-by: Maryam Tahhan <maryam.tahhan@intel.com>
Diffstat (limited to 'puppet-barometer/setup.py')
-rw-r--r--puppet-barometer/setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/puppet-barometer/setup.py b/puppet-barometer/setup.py
new file mode 100644
index 00000000..70c2b3f3
--- /dev/null
+++ b/puppet-barometer/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
+import setuptools
+
+setuptools.setup(
+ setup_requires=['pbr'],
+ pbr=True)