aboutsummaryrefslogtreecommitdiffstats
path: root/patches
diff options
context:
space:
mode:
authorAlexandru Avadanii <Alexandru.Avadanii@enea.com>2017-02-01 00:01:20 +0100
committerAlexandru Avadanii <Alexandru.Avadanii@enea.com>2017-02-01 00:07:23 +0100
commit9be0bfc61b3321ba6b8b6ee5d39cf9238fddd33f (patch)
tree0f18df31ecde883758e9e9ee346abf6a8429fd2d /patches
parent2bde158711c7a93bbe7c03a8967780d31f491f7d (diff)
docker: fpb: Obsolete src override
Fuel@OPNFV recently applied a better fix for using the latest version of fpb, so obsolete our patch. Change-Id: I088fc31177e5c56ce09712b65a3dbd18eb013ce5 Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
Diffstat (limited to 'patches')
-rw-r--r--patches/opnfv-fuel/multiarch-plugins/0001-fpb-Support-multiple-versions-of-packages.patch48
-rw-r--r--patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch4
2 files changed, 2 insertions, 50 deletions
diff --git a/patches/opnfv-fuel/multiarch-plugins/0001-fpb-Support-multiple-versions-of-packages.patch b/patches/opnfv-fuel/multiarch-plugins/0001-fpb-Support-multiple-versions-of-packages.patch
deleted file mode 100644
index 2be2e09..0000000
--- a/patches/opnfv-fuel/multiarch-plugins/0001-fpb-Support-multiple-versions-of-packages.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
-Date: Tue, 23 Aug 2016 15:48:56 +0200
-Subject: [PATCH] fpb: Support multiple versions of packages
-
-This is a temporary change until the fpm installed by pip gets
-the change from [1] included.
-
-[1] https://review.openstack.org/#/c/311031/
-
-Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
----
- build/docker/Dockerfile | 9 ++++++++-
- build/docker/Makefile | 4 ++++
- 2 files changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/build/docker/Dockerfile b/build/docker/Dockerfile
-index 624f233..ab0d0d3 100644
---- a/build/docker/Dockerfile
-+++ b/build/docker/Dockerfile
-@@ -23,5 +23,12 @@ RUN apt-get install -y software-properties-common python-software-properties \
- build-essential ruby-dev rubygems-integration python-pip git rpm createrepo dpkg-dev
-
- RUN gem install fpm
--RUN pip install fuel-plugin-builder
-+
-+# Temporary: fpb needs to be built from sources
-+# RUN pip install fuel-plugin-builder
-+RUN git clone -b INSERT_FPB_BRANCH INSERT_FPB_REPO && cd fuel-plugins && \
-+ (test -z INSERT_FPB_CHANGE || \
-+ (git fetch origin INSERT_FPB_CHANGE && git checkout FETCH_HEAD)) && \
-+ python setup.py sdist && pip install ./dist/fuel-plugin-builder-*.tar.gz && \
-+ cd .. && rm -rf fuel-plugins
- # fuel-infra key
- RUN apt-key adv --keyserver keyserver.ubuntu.com --recv-keys BCE5CC461FA22B08
-index 783881e..74f6346 100644
---- a/build/docker/Makefile
-+++ b/build/docker/Makefile
-@@ -34,6 +34,10 @@ all: .docker
-
- .dockercfg: $(FILES)
- cp Dockerfile ubuntu-builder/Dockerfile
-+ # Only add FPB ENVs when set - needed to fetch, patch and install FPB
-+ test -n "${FPB_REPO}" && sed -i "s;INSERT_FPB_REPO;${FPB_REPO};" ubuntu-builder/Dockerfile || exit 0
-+ test -n "${FPB_BRANCH}" && sed -i "s;INSERT_FPB_BRANCH;${FPB_BRANCH};" ubuntu-builder/Dockerfile || exit 0
-+ test -n "${FPB_CHANGE}" && sed -i "s;INSERT_FPB_CHANGE;${FPB_CHANGE};" ubuntu-builder/Dockerfile || exit 0
- # Only add proxy ENVs where set in host - needed to pull the base Ubuntu image
- test -n "${http_proxy}" && sed -i "s;INSERT_HTTP_PROXY;${http_proxy};" ubuntu-builder/Dockerfile || exit 0
- test -n "${https_proxy}" && sed -i "s;INSERT_HTTPS_PROXY;${https_proxy};" ubuntu-builder/Dockerfile || exit 0
diff --git a/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch b/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch
index ccc37cb..e4f5580 100644
--- a/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch
+++ b/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch
@@ -28,5 +28,5 @@ index 04c4d2b..54aca35 100644
+# FIXME(armband): Newer ffi is broken - https://jira.opnfv.org/browse/ARMBAND-191
+RUN gem install ffi -v 1.9.14
RUN gem install fpm
-
- # Temporary: fpb needs to be built from sources
+ RUN pip install git+https://github.com/openstack/fuel-plugins
+ # fuel-infra key