aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Avadanii <Alexandru.Avadanii@enea.com>2017-04-07 17:13:32 +0200
committerAlexandru Avadanii <Alexandru.Avadanii@enea.com>2017-04-07 15:27:58 +0000
commitbf84b5e16c0c54c76b86393ce674ec6b604ddeb1 (patch)
treeac50b78a799d5e4f77da02e24a720fb5b6705b55
parent5322ced367a79d9e605407cdf51d7c125440b85e (diff)
cleanup: Fuel: docker: remove obsolete ffi patch
This patch is no longer needed, since upstream package repos have fixed meanwhile. Change-Id: Ic73d7e60cce6a1a0c152885caeb30f49d68e7441 Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com> (cherry picked from commit 0716a89e4055be29c140044608293ec5a95b08c6)
-rw-r--r--patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch b/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch
deleted file mode 100644
index f87e853..0000000
--- a/patches/opnfv-fuel/upstream-backports/0002-build-docker-Use-older-ffi-1.9.14.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
-: Copyright (c) 2017 Enea AB and others.
-:
-: All rights reserved. This program and the accompanying materials
-: are made available under the terms of the Apache License, Version 2.0
-: which accompanies this distribution, and is available at
-: http://www.apache.org/licenses/LICENSE-2.0
-::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
-From: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
-Date: Fri, 13 Jan 2017 18:40:08 +0100
-Subject: [PATCH] build/docker: Use older ffi (1.9.14)
-
-`gem install fbm` tries to install the ffi gem too, which has a
-problem in newer versions (>= 1.9.15) - see [1]:
-"AbstractMemory.c:349:48: error: expected ')' before 'PRIsVALUE'"
-
-To bypass the newly introduced issues, use the old version.
-
-[1] https://jira.opnfv.org/browse/ARMBAND-191
-
-JIRA: ARMBAND-191
-
-Signed-off-by: Alexandru Avadanii <Alexandru.Avadanii@enea.com>
----
- build/docker/Dockerfile | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/build/docker/Dockerfile b/build/docker/Dockerfile
-index 04c4d2b..54aca35 100644
---- a/build/docker/Dockerfile
-+++ b/build/docker/Dockerfile
-@@ -22,6 +22,8 @@ RUN apt-get install -y software-properties-common python-software-properties \
- ca-certificates sudo apt-utils lsb-release dosfstools debmirror p7zip-full \
- build-essential ruby-dev rubygems-integration python-pip git rpm createrepo dpkg-dev
-
-+# FIXME(armband): Newer ffi is broken - https://jira.opnfv.org/browse/ARMBAND-191
-+RUN gem install ffi -v 1.9.14
- RUN gem install fpm
- RUN pip install git+https://github.com/openstack/fuel-plugins
- # fuel-infra key