summaryrefslogtreecommitdiffstats
path: root/build/rpm_specs/networking-vpp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'build/rpm_specs/networking-vpp.spec')
-rw-r--r--build/rpm_specs/networking-vpp.spec13
1 files changed, 10 insertions, 3 deletions
diff --git a/build/rpm_specs/networking-vpp.spec b/build/rpm_specs/networking-vpp.spec
index 80687836..75466f94 100644
--- a/build/rpm_specs/networking-vpp.spec
+++ b/build/rpm_specs/networking-vpp.spec
@@ -2,7 +2,7 @@
Summary: OpenStack Networking for VPP
Name: python-networking-vpp
-Version: 17.07
+Version: 18.01
Release: %{release}%{?git}%{?dist}
License: Apache 2.0
@@ -12,7 +12,7 @@ Url: https://github.com/openstack/networking-vpp/
BuildArch: noarch
AutoReq: no
-Requires: vpp
+Requires: vpp python-jwt
Vendor: OpenStack <openstack-dev@lists.openstack.org>
Packager: Feng Pan <fpan@redhat.com>
@@ -27,7 +27,7 @@ Description=Networking VPP ML2 Agent
[Service]
ExecStartPre=/usr/bin/systemctl is-active vpp
-ExecStart=/usr/bin/vpp-agent --config-file /etc/neutron/plugins/ml2/vpp_agent.ini
+ExecStart=/usr/bin/vpp-agent --config-file /etc/neutron/plugins/ml2/vpp_agent.ini --log-file /var/log/neutron/vpp-agent.log
Type=simple
Restart=on-failure
RestartSec=5s
@@ -37,6 +37,13 @@ WantedBy=multi-user.target
EOF
+%preun
+%systemd_preun neutron-vpp-agent.service
+
+%postun
+%systemd_postun
+rm -rf %{python2_sitelib}/networking_vpp*
+
%install
python setup.py install -O1 --root=%{buildroot} --record=INSTALLED_FILES
mkdir -p %{buildroot}%{_libdir}/systemd/system