summaryrefslogtreecommitdiffstats
path: root/build/opnfv-apex-common.spec
diff options
context:
space:
mode:
authorFeng Pan <fpan@redhat.com>2016-04-15 11:43:34 -0400
committerFeng Pan <fpan@redhat.com>2016-04-21 09:37:20 -0400
commit3d56d3211e2ddee0825e79174cfdfbcda70cd20b (patch)
treed67789ed8ec95857711f57b297f0048106cc37ff /build/opnfv-apex-common.spec
parenta412ab4c4a4835bb4a9f4bf0f2ef8c7e965f1aaf (diff)
Adds python IP utility library
Changes include: - IP utility library in python 3 that supports both IPv4 and IPv6 address generation. This library currently includes a single function of generating IP ranges or single IP for a given CIDR. More functionality will be added at a later time to support features such as IP address calculation. - Updated common-function.sh to use python library to generate IP ranges. All existing bash functions are preserved, so any callers will get identical IP ranges as before. - Add dependency to python3 for opnfv-apex-common package. - Add python dependency to build.sh No change is made to interface related functions. Change-Id: Idc6998754f9f3c7a3868ec5b5768f3bb5f78cd90 Signed-off-by: Feng Pan <fpan@redhat.com>
Diffstat (limited to 'build/opnfv-apex-common.spec')
-rw-r--r--build/opnfv-apex-common.spec12
1 files changed, 10 insertions, 2 deletions
diff --git a/build/opnfv-apex-common.spec b/build/opnfv-apex-common.spec
index e618ff0f..89fb4030 100644
--- a/build/opnfv-apex-common.spec
+++ b/build/opnfv-apex-common.spec
@@ -9,9 +9,9 @@ URL: https://gerrit.opnfv.org/gerrit/apex.git
Source0: opnfv-apex-common.tar.gz
BuildArch: noarch
-BuildRequires: python-docutils
+BuildRequires: python-docutils python34-devel
Requires: openstack-tripleo opnfv-apex-sdn opnfv-apex-undercloud openvswitch qemu-kvm bridge-utils libguestfs-tools
-Requires: initscripts net-tools iputils iproute iptables
+Requires: initscripts net-tools iputils iproute iptables python34
%description
Scripts for OPNFV deployment using RDO Manager
@@ -42,6 +42,9 @@ install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-ap
mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
+mkdir -p %{buildroot}%{python3_sitelib}/apex/
+install lib/python/apex/__init__.py %{buildroot}%{python3_sitelib}/apex/
+install lib/python/apex/ip_utils.py %{buildroot}%{python3_sitelib}/apex/
mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
@@ -61,6 +64,9 @@ install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/
%attr(755,root,root) %{_bindir}/opnfv-util
%{_var}/opt/opnfv/lib/common-functions.sh
%{_var}/opt/opnfv/lib/utility-functions.sh
+%{python3_sitelib}/apex/ip_utils.py
+%{python3_sitelib}/apex/__init__.py
+%{python3_sitelib}/apex/__pycache__/*
%{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml
@@ -78,6 +84,8 @@ install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/
%doc %{_docdir}/opnfv/inventory.yaml.example
%changelog
+* Fri Apr 15 2016 Feng Pan <fpan@redhat.com> - 3.0-2
+- Adds python ip utility lib.
* Mon Apr 11 2016 Tim Rozet <trozet@redhat.com> - 3.0-1
- adding opnfv-util
* Mon Apr 04 2016 Dan Radez <dradez@redhat.com> - 3.0-0