summaryrefslogtreecommitdiffstats
path: root/build/opnfv-apex-common.spec
diff options
context:
space:
mode:
authorTim Rozet <trozet@redhat.com>2016-04-11 14:22:27 -0400
committerTim Rozet <trozet@redhat.com>2016-04-12 14:31:50 -0400
commit0717bc3c56ab294f860ef99116754c1fd786cae7 (patch)
treedb98b4d669dab185fc3d6e5a668dbef19002393b /build/opnfv-apex-common.spec
parentf7def4c0913df374087da447548aa6741bc6c8d7 (diff)
Adds Utility functions and failure logging
Patch adds helpful utility functions and automatic parsing of heat output into a readable format indicating where a failure is in a deployment. Example: http://fpaste.org/354210/ New opnfv-util function allows a user to interact with a deployment easily: - opnfv-util undercloud <user> connects user to undercloud VM - opnfv-util debug-stack parses the heat failure output Above arguments also accept partial matches. JIRA: APEX-75 Change-Id: I5ccfee64ee2958de0d00a3b25cd9b29de60c9e20 Signed-off-by: Tim Rozet <trozet@redhat.com>
Diffstat (limited to 'build/opnfv-apex-common.spec')
-rw-r--r--build/opnfv-apex-common.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/build/opnfv-apex-common.spec b/build/opnfv-apex-common.spec
index 1ffac9d2..876755ca 100644
--- a/build/opnfv-apex-common.spec
+++ b/build/opnfv-apex-common.spec
@@ -28,6 +28,7 @@ rst2html docs/release-notes/release-notes.rst docs/release-notes.html
mkdir -p %{buildroot}%{_bindir}/
install ci/deploy.sh %{buildroot}%{_bindir}/opnfv-deploy
install ci/clean.sh %{buildroot}%{_bindir}/opnfv-clean
+install ci/util.sh %{buildroot}%{_bindir}/opnfv-util
mkdir -p %{buildroot}%{_sysconfdir}/opnfv-apex/
install config/deploy/os-nosdn-nofeature-ha.yaml %{buildroot}%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
@@ -40,6 +41,7 @@ install config/network/network_settings.yaml %{buildroot}%{_sysconfdir}/opnfv-ap
mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/
install lib/common-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
+install lib/utility-functions.sh %{buildroot}%{_var}/opt/opnfv/lib/
mkdir -p %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
install lib/installer/onos/onos_gw_mac_update.sh %{buildroot}%{_var}/opt/opnfv/lib/installer/onos/
@@ -56,7 +58,9 @@ install config/inventory/pod_example_settings.yaml %{buildroot}%{_docdir}/opnfv/
%defattr(644, root, root, -)
%attr(755,root,root) %{_bindir}/opnfv-deploy
%attr(755,root,root) %{_bindir}/opnfv-clean
+%attr(755,root,root) %{_bindir}/opnfv-util
%{_var}/opt/opnfv/lib/common-functions.sh
+%{_var}/opt/opnfv/lib/utility-functions.sh
%{_var}/opt/opnfv/lib/installer/onos/onos_gw_mac_update.sh
%{_sysconfdir}/opnfv-apex/os-nosdn-nofeature-ha.yaml
%{_sysconfdir}/opnfv-apex/os-odl_l2-nofeature-ha.yaml