aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJuan Antonio Osorio Robles <jaosorior@redhat.com>2017-01-24 20:25:53 +0200
committerJuan Antonio Osorio Robles <jaosorior@redhat.com>2017-01-24 20:25:53 +0200
commit35e49d5cdd3d0c0cd3963d1cc7d1e1352768cb67 (patch)
treec3c9f7f512ea1c18977c237d5a85bc99e7ecd688 /tools
parent0c60ded964dba7c60d3e0587095db471e1303f18 (diff)
Specify what to do if endpoint map environment don't match
this attempts to make the error message more useful. This error message happens if the environment files containing endpoint map overrides haven't been updated to match the base endpoint map (or the defaults). Change-Id: If53d3a9d7848aed62ebb235afe8b14c18d1b284d
Diffstat (limited to 'tools')
-rwxr-xr-xtools/yaml-validate.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/yaml-validate.py b/tools/yaml-validate.py
index 63e3ce5..19e40d1 100755
--- a/tools/yaml-validate.py
+++ b/tools/yaml-validate.py
@@ -196,8 +196,8 @@ if base_endpoint_map and \
matches = validate_endpoint_map(base_endpoint_map,
env_endpoint_map['map'])
if not matches:
- print("ERROR: %s doesn't match base endpoint map" %
- env_endpoint_map['file'])
+ print("ERROR: %s needs to be updated to match changes in base "
+ "endpoint map" % env_endpoint_map['file'])
failed_files.append(env_endpoint_map['file'])
exit_val |= 1
else: